Contact Support

Which browsers are supported?

In an ideal world, our users could visit medium.com with any browser and know they’re getting the best experience technically possible. In practice, with every browser we support, it takes us longer to build new features and keep existing features bug-free.

To help track what’s supported, we’ve categorized all browsers into one of three tiers:

Tier 1

Our Tier 1 browsers get the full Medium experience. This includes logging in, composing and editing stories, interacting through notes, and using all the other Medium features.

  • Chrome 26 or newer
  • Safari 6.1 or newer
  • Opera 15 or newer
  • Firefox 19 or newer (Iceweasel is not supported)
  • Microsoft Edge

Tier 2

Tier 2 browsers can do everything a Tier 1 browser can except compose and edit stories.

  • Chrome 1 through 25
  • Internet Explorer 10 or newer (including IE mobile)
  • Firefox 4 through 18
  • Safari 3 through 5
  • IOS 5 or newer
  • Android 2 or newer
  • Mobile Safari
  • Mobile Chrome (iOS or Android)

Tier 3

Tier 3 is everything else, like IE 5.5 for Mac or Lynx. You should be able to read Medium articles in these browsers, but we suggest that you download Google Chrome.

FAQ

Why’d you choose these browsers in particular?

Our goal is to always support the last two versions of every major browser. In practice, we are more lenient with some, while others are not yet supported.

When will Internet Explorer (or whatever other browser) be supported?

Our list will certainly change, but as for dates, we’re not making any promises just yet.

What about your apps?

Please see the FAQs for our iOS app and Android app.

My browser is on your supported list, but I’m experiencing issues.

Please let us know by sending an email to yourfriends@medium.com.

Have more questions? Submit a Request